
Application Note 
For the HP 995C Bluetooth-Enabled Printer 

6/29/2002 
1. Introduction  
As a technology leader in the wireless networking market, WIDCOMM’s vision is to enable  
consumers to easily, conveniently and securely access information and services from their  
Bluetooth devices anytime and anywhere – from homes, offices and public places.    
•  BTW™ is a set of software drivers and utilities that seamlessly integrate Bluetooth  
technology into your desktop or laptop computer.    
•  The HP 995C is a Bluetooth-enabled inkjet printer manufactured by Hewlett-Packard, Inc.  
This document describes the procedure for using the HP 995C printer with the BTW software.   
These procedures were tested using the following configuration:  
•  A desktop or laptop computer with an available USB interface and running the  
Microsoft Windows 2000 operating system.  
•  A USB Bluetooth dongle or CF Bluetooth Adapter. 
•  Microsoft Office 2000 (including Outlook 2000) installed on the desktop or laptop  
computer  
•  BTW version 1.2.1.5 or later installed on the desktop or laptop computer.  
•  An HP 995C printer.  The printer must be set up correctly, powered up, and loaded with  
paper.  Both the black-and-white and color ink cartridges must be correctly installed.  
NOTE:  The procedure on a computer running other versions of the Microsoft Windows  
operating system may be slightly different.    
The HP Deskjet 995C advertises two services: "InBox" and "Serial Port". The Serial Port  
service supports the BTW 1.2 Serial Port Profile (SPP) and works correctly provided that you  
install the HP 995C drivers from the CDROM and configure the driver correctly.  
The InBox supports the OBEX profile.  No special print drivers have to be installed in order to  
use this. BTW 1.2 allows you to print business cards, calendar entries, notes, and messages in  
this way. There is also a send-to-Bluetooth option that is added to the Outlook 2000 file menu.   
However, it does an inquiry on device class of Personal-Computer. As a result, the HP printer  
does not show up in the resulting device list.  
2. An Overview of the OBEX Functions  
All of the four OBEX file types will print using the HP 995C. The advantage to using this  
method is that no special print drivers have to be installed. Some of the sequences are rather  
odd and may seem inconsistent, but they will work if you know how to use them. The only  
failure was encountered when trying to send a calendar 2.0 item (*.ics) file. The text of the  
resulting error message indicates that the printer was rejecting the file. This is probably due to  
the fact that the HP 995C does not support this file type (see the message dialog shown below).  

 
 
NOTE:  No special print drivers have to be installed in order to use the OBEX functions 
under BTW.  You do not have to install the print drivers from your HP 995C CDROM in 
order to use these functions.  
  



2.1  TO CREATE AND PRINT A BUSINESS CARD  
1)  In Outlook 2000, click on the Contacts folder.  Using File →New →Contact create a  
contact entry for yourself.  Click on the resulting entry in order to select it.  
2)  Save this entry as a vCard using File →Save As... You will have to use the Save As  
Type pull-down to select "vCard Files (*.vcf)"   
3)  Right click on the BTTray icon and use Setup →Configuration option to access the  
configuration panel.    
4)  Click on the Information Exchange tab.  

 
5)  Under the Send Business Card section, you will see an entry for My Business Card.   
Click on the Browse... button and select the business card that you create. This will set  
your default business card. Use OK to click your way out of this and register your  
choices.  
6)  Inquire for the HP printer. Discover its services.  
7)  Right click on the InBox service and select Send Business Card from the resulting  
menu. BTW will send your business card. The printer will print it.  

 
2.2  TO PRINT A CALENDAR ITEM  
1)  In Outlook 2000, click on the Calendar folder. Click on an existing appointment entry  



in order to select it.  
2)  Save this entry to a file. Do this using File →Save As...  You will have to use the Save  
As Type pull-down to select "iCalendar Format (*.ics)" or "vCalendar Format (*.vcs)".  
3)  Inquire for the HP printer.  Discover its services.  
4)  Right click on the InBox service and select Send Calendar Item from the resulting  
menu. A file chooser will result. BTW will send your calendar item. The printer will  
print it. Use the Files of type pull-down to select either *.ics or *.vcs, then choose the  
file that you created and click on Open.  
NOTE:  This works for a *.vcs file but does not work for a *.ics file.  An error message 
results: “The item could not be sent to (device name).  Error:  The request could not be 
honored.”  This appears to be a printer error rather than a BTW error.  The printer does 
not seem to accept the *.ics format.  To work around this problem, simply use the *.vcs 
format instead.  
  
2.3  TO CREATE AND PRINT A NOTE  
1)  In Outlook 2000, click on the Notes folder. To create a note, right-click in the note  
pane and select New Note then fill in and save the note.    
2)  Inquire for the HP printer. Discover its services.  
3)  Double-click on the InBox service. This will open it just as if you were looking at a  
conventional folder.    
4)  In Outlook 2000, click on an existing note and drag-and-drop it into the opened InBox  
area under BTW. The note will be transferred and automatically printed.  
NOTE:  Under Outlook 2000, you cannot save a note file in the *.vnt format that is required 
in order to right-click on the InBox service and use the Send Note menu item under BTW.   
This vNote file format is not supported by Microsoft.  
 
2.4  TO PRINT AN EMAIL MESSAGE  
1.  In Outlook 2000, click on the "Inbox" folder.    
2.  Inquire for the HP printer.  Discover its services.  
3.  Double-click on the InBox service under BTW.  This will open it just as if you were looking  
at a conventional folder.    
4.  In Outlook 2000, click on an existing email message and drag-and-drop it into the opened  
InBox area under BTW.  The message will be transferred and automatically printed.  
NOTE:  Under Outlook 2000, you cannot save a message file in the *.vmg format that is 
required in order to right-click on the InBox service and use the Send Message menu item 
under BTW.  This vMessage file format is not supported by Microsoft.  
3. BTW and Printer Setup  
This section will describe how to install BTW and the HP 995C print drivers so t hat your  
computer will correctly support the printer over Bluetooth. Once this process is complete, you  
will be able to use the HP 995C just like any other printer under Windows.  The only difference  
will be the fact that there will be no direct physical connection between the printer and your  
desktop or laptop computer.  
NOTE:  The HP 995C printer comes equipped with a USB cable.  This cable is not 
required when you are using the computer over Bluetooth.  The only wire that is required 
is the power cord which connects the printer to the wall.   
  
3.1  CONNECT THE USB Bluetooth dongle or CF Bluetooth Adapter TO YOUR PC OR 
LAPTOP COMPUTER  
Installing the USB Bluetooth dongle or CF Bluetooth Adapter is quick and painless. Connect the 
USB cable to the matching USB connector on your PC, laptop computer, or USB hub.    
  



3.2  INSTALL THE BTW SOFTWARE  
The BTW software is installed from a CDROM using an InstallShield executable. For detailed  
instruction on how to install the software, see the BTW Installation and Uninstallation  
Instructions. This document will be supplied with your BTW CD and has the file name  
readme.doc or readme.pdf.  
  
3.3  INSTALL THE PRINT DRIVER  
Install the HP 995C print drivers from the CD that was supplied with the printer. The process is  
straightforward and obvious. Consult the printer manuals if you require assistance assistance.  
 
3.4  DETERMINE THE ASSIGNED VCOMM PORT UNDER BTW  
In order to properly configure the print driver, you will have to ascertain the virtual com  
(VCOMM) port that will be assigned to the Bluetooth serial port connection. Start by exploring  
My Bluetooth Places under BTW. You will see a display similar to the following:  
 

 
Double-click on the Entire Bluetooth Neighborhood icon.  

 
Use the View →Details menu item (shown above) to switch from large icon view to a detailed  
view of devices as shown below.  



 
Double-click on the printer entry (highlighted above) to discover the services on the printer.   
You should see the two services shown below:  

 
Right-click on the Serial Port service and select Connect to Bluetooth Serial Port from the  
resulting menu shown below.  

 
Once the connection has completed, note the port that has been assigned to the connection.  In  
this example, the VCOMM port was COM3 as shown below.  

 
Right-click on the Serial Port service and select Disconnect Bluetooth Serial Port from the  



resulting menu.  This will terminate the connection.  
 

 
NOTE:  It is important to use the View  → Details option.  Only this setting will allow you 
to discover the VCOMM port that will be used by the serial port profile.  
  
WARNING:  Do not discover or utilize services on any other Bluetooth device prior to 
proceeding to the next section.    
 
3.5  CONFIGURE THE PRINT DRIVER TO USE THE VCOMM PORT  
Now that you know which VCOMM port will be assigned, use the Start →Settings →Printers  
sequence to view your system printers.  You should see an entry for the HP 995C printer.   

 
Right-click on this entry and select Properties from the resulting menu.  Click on the Ports tab  
in the resulting dialog.  



 
You will see a list of all available ports to which the printer can be attached. Checkmark the  
box associated with the VCOMM port that you discovered in the previous section. In this  
example, we discovered that the VCOMM port was COM3. The correct action was to  
checkmark the COM3 entry as shown above.  
Once this is done, click on OK to register your choice. This concludes the setup of the print  
driver. You should be able to use the HP 995C printer just as you would any other Windows  
printer. Because this setup uses Bluetooth wireless technology, no cable is required between  
your laptop or desktop computer and the HP 995C printer. 
4. Using the Printer under Windows 2000 / Me / 98 SE  
  
4.1  IMPORTANT:  ALWAYS CONNECT TO THE SERVICE BEFORE USING THE 
PRINTER  
This print driver is not Bluetooth aware.  It has no knowledge of which particular Bluetooth  
device that it should connect to when attempting to print. You must manually connect to the  
correct serial port service at least once so that the print driver can direct its data to the proper  
service on the proper device.  For this reason, you must always perform the following sequence  
at least once before attempting to use the printer.  If at any time you connect to a serial port  
service on another Bluetooth device, you must repeat this sequence so that the Serial Port  
service on the HP 995C will be the default service that is assigned to the VCOMM port that the  
printer is attempting to use.  
Double-click on the printer entry to discover the services on the printer.  You should see the two  
services shown below: 



 
Right-click on the Serial Port service and select Connect to Bluetooth Serial Port from the  
resulting menu shown below. 

 
Wait for the connection to complete.  

 
Right-click on the Serial Port service and select Disconnect Bluetooth Serial Port from the  
resulting menu.  This will terminate the connection. 
 

 
The default service is now the Serial Port service on the HP 995C printer.  This is the port that  
the print driver will attempt to use.  
5. Using the Printer under Windows XP  
If you are running Windows XP on your laptop of desktop computer, using the HP 995C is a  
special challenge. The driver CD that was being shipped at the time of the writing of this  



document (v 4.0) did not run under Windows XP. Fortunately, there is a way to set up the  
printer using the drivers that are supplied with the Windows XP operating system.    
5.1  DETERMINE THE VCOMM PORT  
Start by following the instructions outlined in Sections 3.1 through 3.4 in order to determine the  
VCOMM port that will be used by the Serial Port Profile.  
WARNING:  If you plan to print a test page, do not discover services on any other 
Bluetooth device prior to proceeding to the next section.    
5.2  SET UP THE PRINT DRIVER  
Use the following sequence to begin setting up your printer:    
Start →Control Panel →Printers and Faxes  
This will bring up a list of all installed printers. Click on the Add a Printer button. This will  
activate the Add Printer Wizard as shown below. Then click on Next> to continue.    

 
You should specify that you are using a Local printer attached to this computer and uncheck the  
box entitled Automatically detect and install my Plug and Play printer as shown below. Then  
click on Next> to continue.    



 
You will be asked to specify the printer port.  Use the pull-down selector to choose the  
VCOMM port that you discovered by following the procedures outlined in Sections 3.1 through  
3.4.  In this example, the VCOMM port was COM3.  When you are finished, click on Next> to  
continue.    

 
You will now be asked to specify the print driver to use.  Choose a manufacturer name of HP  
and the hp deskjet 990c as the printer. Click on Next> to continue.    



 
You will now be asked to specify a printer name. You can leave it as the default or change it to  
hp deskjet 995c.  

 
Continue to click on Next> in all of the remaining dialogs to finish installing the driver.  You  
may want to print a test page.  If your printer is set up correctly, the test page should print out  
on the HP 995C printer.  [ See the next section for an important caveat ]  
WARNING:  Using the HP 990C print driver appears to work in our limited tests.  This 
does not guarantee that it will support all of the functionality of the HP 995C.  WIDCOMM 



makes no claims of suitability or functionality for this configuration.  WIDCOMM assumes 
no liability for using this method of printing under Windows XP.  Use this method at your  
own risk.  
  
5.3  IMPORTANT:  ALWAYS CONNECT TO THE SERVICE BEFORE USING THE 
PRINTER  
This print driver is not Bluetooth aware.  It has no knowledge of which particular Bluetooth  
device that it should connect to when attempting to print.  You must manually connect to the  
correct serial port service at least once so that the print driver can direct its data to the pro per  
service on the proper device.  For this reason, you must always perform the following sequence  
at least once before attempting to use the printer.  If at any time you connect to a serial port  
service on another Bluetooth device, you must repeat this sequence so that the Serial Port  
service on the HP 995C will be the default service that is assigned to the VCOMM port that the  
printer is attempting to use.  
 
Start by inquiring for the HP995C device.  Double-click on that device to perform a service  
discovery.  You will see a display similar to the one shown below:  
 

 
Right-click on the Serial Port service.  Choose Connect to Bluetooth Serial Port from the  
resulting menu as shown below:  



 
This will create a serial port connection (see below).  You can leave t he connection intact or  
disconnect if you wish.    

 
Since this was the last serial port connection that was made, the Serial Port service on the HP  
995C device will be automatically assigned when the print driver attempts to use the VCOMM  
port (COM3 in this example). If you subsequently connect to a serial port service on another  
Bluetooth device, this default association will be destroyed and your printer will cease to  
function.   
 
6. For Troubleshooting or Further Information  
For additional technical information or troubleshooting advice, see the following WIDCOMM  
documents:  
•  BTW Installation and Uninstallation Instructions. These are supplied with your BTW  
CD as readme.doc or readme.pdf.  
•  BTW Windows 2000 Release Notes.  
•  BTW User Interface User’s Guide and Reference.  
If you still cannot succeed using the steps outlined in the document, contact WIDCOMM  



technical support.  The preferred method of doing this is to use the on-line forms for BTW.  In  
order to access these forms, you will need the user name and password that was supplied along  
with your WIDCOMM product.  You can access these forms from  
http://www.widcomm.com/Support/index.asp or send an email to support@widcomm.com.  
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